Friday, 20 February 2009

koha!

Spent a bit of time tinkering with koha in my spare time recently. Threw in a few trivial patches (once I'd got my head round git). However Some notes here for those installing on Debian Lenny (current 'testing'

1) Nearly all the required perl modules are available directly from the repos, the exception being SMS::Send (which needs Class::Adapter) -- Thise can be installed with the ever so handy dh-make-perl which converts your CPAN into .debs (sadly it still doesn't help with other conversion issues).

# dh-make-perl --build --cpan Class::Adapter ; dpkg -i libclass-adapter-perl_1.05-1_all.deb
# dh-make-perl --build --cpan SMS::Send ; dpkg -i libsms-send-perl_0.05-1_all.deb

2) I'll write up the rest as a HOWTO soon....

1 comment:

Mark said...

Wasn't Lenny promoted to Stable the weekend before you wrote this?